summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 27 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index cab5b7acc..8056ada05 100644
--- a/configure.in
+++ b/configure.in
@@ -936,19 +936,38 @@ AC_TRY_COMPILE([
936#ifdef HAVE_LASTLOG_H 936#ifdef HAVE_LASTLOG_H
937# include <lastlog.h> 937# include <lastlog.h>
938#endif 938#endif
939#ifdef PATHS_H 939#ifdef HAVE_PATHS_H
940# include <paths.h> 940# include <paths.h>
941#endif 941#endif
942 ], 942 ],
943 [ char *lastlog = LASTLOG_FILE; ], 943 [ char *lastlog = LASTLOG_FILE; ],
944 [ AC_MSG_RESULT(yes) ], 944 [ AC_MSG_RESULT(yes) ],
945 [ AC_MSG_RESULT(no) 945 [
946 system_lastlog_path=no ] 946 AC_MSG_RESULT(no)
947 AC_MSG_CHECKING([if your system defines _PATH_LASTLOG])
948 AC_TRY_COMPILE([
949#include <sys/types.h>
950#include <utmp.h>
951#ifdef HAVE_LASTLOG_H
952# include <lastlog.h>
953#endif
954#ifdef HAVE_PATHS_H
955# include <paths.h>
956#endif
957 ],
958 [ char *lastlog = _PATH_LASTLOG; ],
959 [ AC_MSG_RESULT(yes) ],
960 [
961 AC_MSG_RESULT(no),
962 system_lastlog_path=no
963 ])
964 ]
947) 965)
966
948if test -z "$conf_lastlog_location"; then 967if test -z "$conf_lastlog_location"; then
949 if test x"$system_lastlog_path" = x"no" ; then 968 if test x"$system_lastlog_path" = x"no" ; then
950 for f in /var/log/lastlog /usr/adm/lastlog /var/adm/lastlog /etc/security/lastlog ; do 969 for f in /var/log/lastlog /usr/adm/lastlog /var/adm/lastlog /etc/security/lastlog ; do
951 if test -e $f ; then 970 if test -d "$f" -o -e "$f" ; then
952 conf_lastlog_location=$f 971 conf_lastlog_location=$f
953 fi 972 fi
954 done 973 done
@@ -968,7 +987,7 @@ AC_MSG_CHECKING([if your system defines UTMP_FILE])
968AC_TRY_COMPILE([ 987AC_TRY_COMPILE([
969#include <sys/types.h> 988#include <sys/types.h>
970#include <utmp.h> 989#include <utmp.h>
971#ifdef PATHS_H 990#ifdef HAVE_PATHS_H
972# include <paths.h> 991# include <paths.h>
973#endif 992#endif
974 ], 993 ],
@@ -998,7 +1017,7 @@ AC_MSG_CHECKING([if your system defines WTMP_FILE])
998AC_TRY_COMPILE([ 1017AC_TRY_COMPILE([
999#include <sys/types.h> 1018#include <sys/types.h>
1000#include <utmp.h> 1019#include <utmp.h>
1001#ifdef PATHS_H 1020#ifdef HAVE_PATHS_H
1002# include <paths.h> 1021# include <paths.h>
1003#endif 1022#endif
1004 ], 1023 ],
@@ -1034,7 +1053,7 @@ AC_TRY_COMPILE([
1034#ifdef HAVE_UTMPX_H 1053#ifdef HAVE_UTMPX_H
1035#include <utmpx.h> 1054#include <utmpx.h>
1036#endif 1055#endif
1037#ifdef PATHS_H 1056#ifdef HAVE_PATHS_H
1038# include <paths.h> 1057# include <paths.h>
1039#endif 1058#endif
1040 ], 1059 ],
@@ -1059,7 +1078,7 @@ AC_TRY_COMPILE([
1059#ifdef HAVE_UTMPX_H 1078#ifdef HAVE_UTMPX_H
1060#include <utmpx.h> 1079#include <utmpx.h>
1061#endif 1080#endif
1062#ifdef PATHS_H 1081#ifdef HAVE_PATHS_H
1063# include <paths.h> 1082# include <paths.h>
1064#endif 1083#endif
1065 ], 1084 ],