summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ed4d05199..90e75bef4 100644
--- a/configure.in
+++ b/configure.in
@@ -266,8 +266,14 @@ AC_ARG_WITH(libs,
266# Checks for libraries. 266# Checks for libraries.
267AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***])) 267AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***]))
268AC_CHECK_LIB(util, login, AC_DEFINE(HAVE_LIBUTIL_LOGIN) LIBS="$LIBS -lutil") 268AC_CHECK_LIB(util, login, AC_DEFINE(HAVE_LIBUTIL_LOGIN) LIBS="$LIBS -lutil")
269AC_CHECK_LIB(pcre, pcre_info, 269
270 AC_DEFINE(HAVE_LIBPCRE) LIBS="$LIBS -lpcreposix -lpcre") 270AC_CHECK_FUNC(regcomp,
271 [],
272 [
273 AC_CHECK_LIB(pcre, pcre_info,
274 AC_DEFINE(HAVE_LIBPCRE) LIBS="$LIBS -lpcreposix -lpcre")
275 ]
276)
271 277
272if test -z "$no_libsocket" ; then 278if test -z "$no_libsocket" ; then
273 AC_CHECK_LIB(nsl, yp_match, , ) 279 AC_CHECK_LIB(nsl, yp_match, , )
@@ -1531,6 +1537,7 @@ else
1531 RAND_MSG="EGD ($EGD_SOCKET)" 1537 RAND_MSG="EGD ($EGD_SOCKET)"
1532 else 1538 else
1533 RAND_MSG="Builtin (timeout $entropy_timeout)" 1539 RAND_MSG="Builtin (timeout $entropy_timeout)"
1540 BUILTIN_RNG=1
1534 fi 1541 fi
1535fi 1542fi
1536 1543
@@ -1574,3 +1581,9 @@ echo " Libraries: ${LIBS}"
1574 1581
1575echo "" 1582echo ""
1576 1583
1584if test ! -z "$BUILTIN_RNG" ; then
1585 echo "WARNING: you are using the builtin random number collection service."
1586 echo "Please read WARNING.RNG and request that your OS vendor includes"
1587 echo "/dev/random in future versions of their OS."
1588 echo ""
1589fi