summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 90aadd98f..4f1e4796e 100644
--- a/configure.in
+++ b/configure.in
@@ -55,6 +55,8 @@ case "$host" in
55 ;; 55 ;;
56*-*-linux*) 56*-*-linux*)
57 no_dev_ptmx=1 57 no_dev_ptmx=1
58 AC_DEFINE(DONT_TRY_OTHER_AF)
59 inet6_default_4in6=yes
58 ;; 60 ;;
59*-*-netbsd*) 61*-*-netbsd*)
60 need_dash_r=1 62 need_dash_r=1
@@ -788,6 +790,26 @@ AC_ARG_WITH(ipv4-default,
788 ] 790 ]
789) 791)
790 792
793AC_MSG_CHECKING([to convert IPv4 in IPv6-mapped addresses])
794AC_ARG_WITH(4in6,
795 [ --with-4in6 Check for and convert IPv4 in IPv6 mapped addresses],
796 [
797 if test "x$withval" != "xno" ; then
798 AC_MSG_RESULT(yes)
799 AC_DEFINE(IPV4_IN_IPV6)
800 else
801 AC_MSG_RESULT(no)
802 fi
803 ],[
804 if test "x$inet6_default_4in6" = "xyes"; then
805 AC_MSG_RESULT([yes (default)])
806 AC_DEFINE(IPV4_IN_IPV6)
807 else
808 AC_MSG_RESULT([no (default)])
809 fi
810 ]
811)
812
791# Where to place sshd.pid 813# Where to place sshd.pid
792piddir=/var/run 814piddir=/var/run
793AC_ARG_WITH(pid-dir, 815AC_ARG_WITH(pid-dir,