summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 30 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 9edb6ac6e..d31bf1a72 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.263 2001/03/10 21:50:45 tim Exp $ 1# $Id: configure.in,v 1.264 2001/03/12 01:32:12 tim Exp $
2 2
3AC_INIT(ssh.c) 3AC_INIT(ssh.c)
4 4
@@ -1060,6 +1060,34 @@ if test "x$ac_cv_have_int64_t" = "xno" -a \
1060 "x$ac_cv_sizeof_long_int" != "x8" -a \ 1060 "x$ac_cv_sizeof_long_int" != "x8" -a \
1061 "x$ac_cv_sizeof_long_long_int" = "x0" ; then 1061 "x$ac_cv_sizeof_long_long_int" = "x0" ; then
1062 NO_SFTP='#' 1062 NO_SFTP='#'
1063else
1064dnl test snprintf (broken on SCO w/gcc)
1065 AC_TRY_RUN(
1066 [
1067#include <stdio.h>
1068#include <string.h>
1069#ifdef HAVE_SNPRINTF
1070main()
1071{
1072 char buf[50];
1073 char expected_out[50];
1074 int mazsize = 50 ;
1075#if (SIZEOF_LONG_INT == 8)
1076 long int num = 0x7fffffffffffffff;
1077#else
1078 long long num = 0x7fffffffffffffff;
1079#endif
1080 strcpy(expected_out, "9223372036854775807");
1081 snprintf(buf, mazsize, "%lld", num);
1082 if(strcmp(buf, expected_out) != 0)
1083 exit(1);
1084 exit(0);
1085}
1086#else
1087main() { exit(0); }
1088#endif
1089 ], [ true ], [ AC_DEFINE(BROKEN_SNPRINTF) ]
1090 )
1063fi 1091fi
1064AC_SUBST(NO_SFTP) 1092AC_SUBST(NO_SFTP)
1065 1093
@@ -1292,7 +1320,7 @@ AC_ARG_WITH(prngd-socket,
1292 if test -z "$RANDOM_POOL" ; then 1320 if test -z "$RANDOM_POOL" ; then
1293 AC_MSG_CHECKING(for PRNGD/EGD socket) 1321 AC_MSG_CHECKING(for PRNGD/EGD socket)
1294 # Insert other locations here 1322 # Insert other locations here
1295 for sock in /var/run/egd-pool /etc/entropy; do 1323 for sock in /var/run/egd-pool /dev/egd-pool /etc/entropy; do
1296 if test -r $sock && $TEST_MINUS_S_SH -c "test -S $sock -o -p $sock" ; then 1324 if test -r $sock && $TEST_MINUS_S_SH -c "test -S $sock -o -p $sock" ; then
1297 PRNGD_SOCKET="$sock" 1325 PRNGD_SOCKET="$sock"
1298 AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET") 1326 AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET")
@@ -1427,7 +1455,6 @@ AC_ARG_WITH(default-path,
1427 [ 1455 [
1428/* find out what STDPATH is */ 1456/* find out what STDPATH is */
1429#include <stdio.h> 1457#include <stdio.h>
1430#include "config.h"
1431#ifdef HAVE_PATHS_H 1458#ifdef HAVE_PATHS_H
1432# include <paths.h> 1459# include <paths.h>
1433#endif 1460#endif