summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in68
1 files changed, 64 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 649c789dc..2a4a2c7de 100644
--- a/configure.in
+++ b/configure.in
@@ -70,6 +70,57 @@ AC_CHECK_FUNC(daemon,
70 [AC_CHECK_LIB(bsd, daemon, [LIBS="$LIBS -lbsd"; AC_DEFINE(HAVE_DAEMON)])] 70 [AC_CHECK_LIB(bsd, daemon, [LIBS="$LIBS -lbsd"; AC_DEFINE(HAVE_DAEMON)])]
71) 71)
72 72
73dnl Checks for data types
74AC_CHECK_SIZEOF(short int, 2)
75AC_CHECK_SIZEOF(int, 4)
76AC_CHECK_SIZEOF(long int, 4)
77AC_CHECK_SIZEOF(long long int, 8)
78
79dnl More checks for data types
80AC_MSG_CHECKING([For quad_t])
81AC_TRY_COMPILE(
82 [#include <sys/types.h>],
83 [quad_t a; a = 1235;],
84 [
85 AC_DEFINE(HAVE_QUAD_T)
86 AC_MSG_RESULT(yes)
87 ],
88 [AC_MSG_RESULT(no)]
89)
90
91AC_MSG_CHECKING([For intXX_t types])
92AC_TRY_COMPILE(
93 [#include <sys/types.h>],
94 [int16_t a; int32_t b; a = 1235; b = 1235;],
95 [
96 AC_DEFINE(HAVE_INTXX_T)
97 AC_MSG_RESULT(yes)
98 ],
99 [AC_MSG_RESULT(no)]
100)
101
102AC_MSG_CHECKING([For u_intXX_t types])
103AC_TRY_COMPILE(
104 [#include <sys/types.h>],
105 [u_int16_t c; u_int32_t d; c = 1235; d = 1235;],
106 [
107 AC_DEFINE(HAVE_U_INTXX_T)
108 AC_MSG_RESULT(yes)
109 ],
110 [AC_MSG_RESULT(no)]
111)
112
113AC_MSG_CHECKING([For uintXX_t types])
114AC_TRY_COMPILE(
115 [#include <sys/types.h>],
116 [uint16_t c; uint32_t d; c = 1235; d = 1235;],
117 [
118 AC_DEFINE(HAVE_UINTXX_T)
119 AC_MSG_RESULT(yes)
120 ],
121 [AC_MSG_RESULT(no)]
122)
123
73dnl Check whether use wants to disable the external ssh-askpass 124dnl Check whether use wants to disable the external ssh-askpass
74INSTALL_ASKPASS="yes" 125INSTALL_ASKPASS="yes"
75AC_MSG_CHECKING([whether to enable external ssh-askpass support]) 126AC_MSG_CHECKING([whether to enable external ssh-askpass support])
@@ -158,14 +209,23 @@ dnl Look for lastlog location
158AC_MSG_CHECKING([location of lastlog file]) 209AC_MSG_CHECKING([location of lastlog file])
159for lastlog in /var/log/lastlog /var/adm/lastlog /etc/security/lastlog ; do 210for lastlog in /var/log/lastlog /var/adm/lastlog /etc/security/lastlog ; do
160 if test -f $lastlog ; then 211 if test -f $lastlog ; then
161 gotlastlog="yes" 212 gotlastlog="file"
162 AC_MSG_RESULT($lastlog) 213 break
163 AC_DEFINE_UNQUOTED(LASTLOG_LOCATION, "$lastlog") 214 fi
215 if test -d $lastlog ; then
216 gotlastlog="dir"
164 break 217 break
165 fi 218 fi
166done 219done
167if test -z "$gotlastlog" ; then 220if test -z "$gotlastlog" ; then
168 AC_MSG_ERROR([*** Cannot find lastlog ***]) 221 AC_MSG_ERROR([*** Cannot find lastlog ***])
222else
223 if test "x$gotlastlog" = "xdir" ; then
224 AC_DEFINE(LASTLOG_IS_DIR)
225 AC_MSG_ERROR([*** Directory-based lastlogs are not yet supported ***])
226 fi
227 AC_MSG_RESULT($lastlog)
228 AC_DEFINE_UNQUOTED(LASTLOG_LOCATION, "$lastlog")
169fi 229fi
170 230
171AC_MSG_CHECKING([whether libc defines __progname]) 231AC_MSG_CHECKING([whether libc defines __progname])
@@ -191,7 +251,7 @@ AC_ARG_WITH(kerberos4,
191) 251)
192 252
193dnl Check whether user wants AFS support 253dnl Check whether user wants AFS support
194AC_ARG_WITH(kerberos4, 254AC_ARG_WITH(afs,
195 [ --with-afs Enable AFS support], 255 [ --with-afs Enable AFS support],
196 [ 256 [
197 AC_DEFINE(AFS) 257 AC_DEFINE(AFS)