summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4e5bc602d..dd3e16841 100644
--- a/configure.in
+++ b/configure.in
@@ -184,8 +184,10 @@ AC_TRY_COMPILE(
184 184
185AC_MSG_CHECKING([For socklen_t]) 185AC_MSG_CHECKING([For socklen_t])
186AC_TRY_COMPILE( 186AC_TRY_COMPILE(
187 [#include <sys/types.h>], 187 [
188 [#include <sys/socket.h>], 188 #include <sys/types.h>
189 #include <sys/socket.h>
190 ],
189 [socklen_t foo; foo = 1235;], 191 [socklen_t foo; foo = 1235;],
190 [ 192 [
191 AC_DEFINE(HAVE_SOCKLEN_T) 193 AC_DEFINE(HAVE_SOCKLEN_T)
@@ -197,7 +199,6 @@ AC_TRY_COMPILE(
197AC_MSG_CHECKING([For size_t]) 199AC_MSG_CHECKING([For size_t])
198AC_TRY_COMPILE( 200AC_TRY_COMPILE(
199 [#include <sys/types.h>], 201 [#include <sys/types.h>],
200 [#include <sys/socket.h>],
201 [size_t foo; foo = 1235;], 202 [size_t foo; foo = 1235;],
202 [ 203 [
203 AC_DEFINE(HAVE_SIZE_T) 204 AC_DEFINE(HAVE_SIZE_T)