summaryrefslogtreecommitdiff
path: root/debian/patches/consolekit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/consolekit.patch')
-rw-r--r--debian/patches/consolekit.patch44
1 files changed, 22 insertions, 22 deletions
diff --git a/debian/patches/consolekit.patch b/debian/patches/consolekit.patch
index b97bf0cd5..65b6feb71 100644
--- a/debian/patches/consolekit.patch
+++ b/debian/patches/consolekit.patch
@@ -1,4 +1,4 @@
1From 05609b1cb381eafb999214bf4a95138e63abdbf2 Mon Sep 17 00:00:00 2001 1From efe70e315cfcc70e765ebd070e83528a6be6c125 Mon Sep 17 00:00:00 2001
2From: Colin Watson <cjwatson@ubuntu.com> 2From: Colin Watson <cjwatson@ubuntu.com>
3Date: Sun, 9 Feb 2014 16:09:57 +0000 3Date: Sun, 9 Feb 2014 16:09:57 +0000
4Subject: Add support for registering ConsoleKit sessions on login 4Subject: Add support for registering ConsoleKit sessions on login
@@ -24,24 +24,24 @@ Patch-Name: consolekit.patch
24 create mode 100644 consolekit.h 24 create mode 100644 consolekit.h
25 25
26diff --git a/Makefile.in b/Makefile.in 26diff --git a/Makefile.in b/Makefile.in
27index f979926..b2dbead 100644 27index 35c6fd6..598d55a 100644
28--- a/Makefile.in 28--- a/Makefile.in
29+++ b/Makefile.in 29+++ b/Makefile.in
30@@ -94,7 +94,8 @@ SSHDOBJS=sshd.o auth-rhosts.o auth-passwd.o auth-rsa.o auth-rh-rsa.o \ 30@@ -97,7 +97,8 @@ SSHDOBJS=sshd.o auth-rhosts.o auth-passwd.o auth-rsa.o auth-rh-rsa.o \
31 sftp-server.o sftp-common.o \ 31 sftp-server.o sftp-common.o \
32 roaming_common.o roaming_serv.o \ 32 roaming_common.o roaming_serv.o \
33 sandbox-null.o sandbox-rlimit.o sandbox-systrace.o sandbox-darwin.o \ 33 sandbox-null.o sandbox-rlimit.o sandbox-systrace.o sandbox-darwin.o \
34- sandbox-seccomp-filter.o 34- sandbox-seccomp-filter.o sandbox-capsicum.o
35+ sandbox-seccomp-filter.o \ 35+ sandbox-seccomp-filter.o sandbox-capsicum.o \
36+ consolekit.o 36+ consolekit.o
37 37
38 MANPAGES = moduli.5.out scp.1.out ssh-add.1.out ssh-agent.1.out ssh-keygen.1.out ssh-keyscan.1.out ssh.1.out sshd.8.out sftp-server.8.out sftp.1.out ssh-keysign.8.out ssh-pkcs11-helper.8.out sshd_config.5.out ssh_config.5.out 38 MANPAGES = moduli.5.out scp.1.out ssh-add.1.out ssh-agent.1.out ssh-keygen.1.out ssh-keyscan.1.out ssh.1.out sshd.8.out sftp-server.8.out sftp.1.out ssh-keysign.8.out ssh-pkcs11-helper.8.out sshd_config.5.out ssh_config.5.out
39 MANPAGES_IN = moduli.5 scp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 ssh.1 sshd.8 sftp-server.8 sftp.1 ssh-keysign.8 ssh-pkcs11-helper.8 sshd_config.5 ssh_config.5 39 MANPAGES_IN = moduli.5 scp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 ssh.1 sshd.8 sftp-server.8 sftp.1 ssh-keysign.8 ssh-pkcs11-helper.8 sshd_config.5 ssh_config.5
40diff --git a/configure b/configure 40diff --git a/configure b/configure
41index ceb1b5d..78bbcd0 100755 41index 5a9db2d..57b68e2 100755
42--- a/configure 42--- a/configure
43+++ b/configure 43+++ b/configure
44@@ -738,6 +738,7 @@ with_privsep_user 44@@ -740,6 +740,7 @@ with_privsep_user
45 with_sandbox 45 with_sandbox
46 with_selinux 46 with_selinux
47 with_kerberos5 47 with_kerberos5
@@ -49,15 +49,15 @@ index ceb1b5d..78bbcd0 100755
49 with_privsep_path 49 with_privsep_path
50 with_xauth 50 with_xauth
51 enable_strip 51 enable_strip
52@@ -1428,6 +1429,7 @@ Optional Packages: 52@@ -1432,6 +1433,7 @@ Optional Packages:
53 --with-sandbox=style Specify privilege separation sandbox (no, darwin, rlimit, systrace, seccomp_filter) 53 --with-sandbox=style Specify privilege separation sandbox (no, darwin, rlimit, systrace, seccomp_filter, capsicum)
54 --with-selinux Enable SELinux support 54 --with-selinux Enable SELinux support
55 --with-kerberos5=PATH Enable Kerberos 5 support 55 --with-kerberos5=PATH Enable Kerberos 5 support
56+ --with-consolekit Enable ConsoleKit support 56+ --with-consolekit Enable ConsoleKit support
57 --with-privsep-path=xxx Path for privilege separation chroot (default=/var/empty) 57 --with-privsep-path=xxx Path for privilege separation chroot (default=/var/empty)
58 --with-xauth=PATH Specify path to xauth program 58 --with-xauth=PATH Specify path to xauth program
59 --with-maildir=/path/to/mail Specify your system mail directory 59 --with-maildir=/path/to/mail Specify your system mail directory
60@@ -16375,6 +16377,135 @@ fi 60@@ -17215,6 +17217,135 @@ fi
61 61
62 62
63 63
@@ -193,7 +193,7 @@ index ceb1b5d..78bbcd0 100755
193 # Looking for programs, paths and files 193 # Looking for programs, paths and files
194 194
195 PRIVSEP_PATH=/var/empty 195 PRIVSEP_PATH=/var/empty
196@@ -18902,6 +19033,7 @@ echo " MD5 password support: $MD5_MSG" 196@@ -19744,6 +19875,7 @@ echo " MD5 password support: $MD5_MSG"
197 echo " libedit support: $LIBEDIT_MSG" 197 echo " libedit support: $LIBEDIT_MSG"
198 echo " Solaris process contract support: $SPC_MSG" 198 echo " Solaris process contract support: $SPC_MSG"
199 echo " Solaris project support: $SP_MSG" 199 echo " Solaris project support: $SP_MSG"
@@ -202,10 +202,10 @@ index ceb1b5d..78bbcd0 100755
202 echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 202 echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
203 echo " BSD Auth support: $BSD_AUTH_MSG" 203 echo " BSD Auth support: $BSD_AUTH_MSG"
204diff --git a/configure.ac b/configure.ac 204diff --git a/configure.ac b/configure.ac
205index 4c1a658..d7d500a 100644 205index 90eebf5..e2289cd 100644
206--- a/configure.ac 206--- a/configure.ac
207+++ b/configure.ac 207+++ b/configure.ac
208@@ -3841,6 +3841,30 @@ AC_ARG_WITH([kerberos5], 208@@ -4070,6 +4070,30 @@ AC_ARG_WITH([kerberos5],
209 AC_SUBST([GSSLIBS]) 209 AC_SUBST([GSSLIBS])
210 AC_SUBST([K5LIBS]) 210 AC_SUBST([K5LIBS])
211 211
@@ -236,7 +236,7 @@ index 4c1a658..d7d500a 100644
236 # Looking for programs, paths and files 236 # Looking for programs, paths and files
237 237
238 PRIVSEP_PATH=/var/empty 238 PRIVSEP_PATH=/var/empty
239@@ -4641,6 +4665,7 @@ echo " MD5 password support: $MD5_MSG" 239@@ -4871,6 +4895,7 @@ echo " MD5 password support: $MD5_MSG"
240 echo " libedit support: $LIBEDIT_MSG" 240 echo " libedit support: $LIBEDIT_MSG"
241 echo " Solaris process contract support: $SPC_MSG" 241 echo " Solaris process contract support: $SPC_MSG"
242 echo " Solaris project support: $SP_MSG" 242 echo " Solaris project support: $SP_MSG"
@@ -521,7 +521,7 @@ index 0000000..8ce3716
521+ 521+
522+#endif /* USE_CONSOLEKIT */ 522+#endif /* USE_CONSOLEKIT */
523diff --git a/monitor.c b/monitor.c 523diff --git a/monitor.c b/monitor.c
524index e8d63eb..9bc4f0b 100644 524index 88f472e..8ffea4f 100644
525--- a/monitor.c 525--- a/monitor.c
526+++ b/monitor.c 526+++ b/monitor.c
527@@ -98,6 +98,9 @@ 527@@ -98,6 +98,9 @@
@@ -575,7 +575,7 @@ index e8d63eb..9bc4f0b 100644
575 575
576 for (;;) 576 for (;;)
577 monitor_read(pmonitor, mon_dispatch, NULL); 577 monitor_read(pmonitor, mon_dispatch, NULL);
578@@ -2492,3 +2508,30 @@ mm_answer_jpake_check_confirm(int sock, Buffer *m) 578@@ -2493,3 +2509,30 @@ mm_answer_jpake_check_confirm(int sock, Buffer *m)
579 } 579 }
580 580
581 #endif /* JPAKE */ 581 #endif /* JPAKE */
@@ -672,7 +672,7 @@ index 4d12e29..360fb9f 100644
672+ 672+
673 #endif /* _MM_WRAP_H_ */ 673 #endif /* _MM_WRAP_H_ */
674diff --git a/session.c b/session.c 674diff --git a/session.c b/session.c
675index b4d74d9..15bdb1b 100644 675index 5ddd82a..14df226 100644
676--- a/session.c 676--- a/session.c
677+++ b/session.c 677+++ b/session.c
678@@ -92,6 +92,7 @@ 678@@ -92,6 +92,7 @@
@@ -683,7 +683,7 @@ index b4d74d9..15bdb1b 100644
683 683
684 #if defined(KRB5) && defined(USE_AFS) 684 #if defined(KRB5) && defined(USE_AFS)
685 #include <kafs.h> 685 #include <kafs.h>
686@@ -1132,6 +1133,9 @@ do_setup_env(Session *s, const char *shell) 686@@ -1155,6 +1156,9 @@ do_setup_env(Session *s, const char *shell)
687 #if !defined (HAVE_LOGIN_CAP) && !defined (HAVE_CYGWIN) 687 #if !defined (HAVE_LOGIN_CAP) && !defined (HAVE_CYGWIN)
688 char *path = NULL; 688 char *path = NULL;
689 #endif 689 #endif
@@ -693,7 +693,7 @@ index b4d74d9..15bdb1b 100644
693 693
694 /* Initialize the environment. */ 694 /* Initialize the environment. */
695 envsize = 100; 695 envsize = 100;
696@@ -1276,6 +1280,11 @@ do_setup_env(Session *s, const char *shell) 696@@ -1299,6 +1303,11 @@ do_setup_env(Session *s, const char *shell)
697 child_set_env(&env, &envsize, "KRB5CCNAME", 697 child_set_env(&env, &envsize, "KRB5CCNAME",
698 s->authctxt->krb5_ccname); 698 s->authctxt->krb5_ccname);
699 #endif 699 #endif
@@ -705,7 +705,7 @@ index b4d74d9..15bdb1b 100644
705 #ifdef USE_PAM 705 #ifdef USE_PAM
706 /* 706 /*
707 * Pull in any environment variables that may have 707 * Pull in any environment variables that may have
708@@ -2320,6 +2329,10 @@ session_pty_cleanup2(Session *s) 708@@ -2348,6 +2357,10 @@ session_pty_cleanup2(Session *s)
709 709
710 debug("session_pty_cleanup: session %d release %s", s->self, s->tty); 710 debug("session_pty_cleanup: session %d release %s", s->self, s->tty);
711 711
@@ -717,7 +717,7 @@ index b4d74d9..15bdb1b 100644
717 if (s->pid != 0) 717 if (s->pid != 0)
718 record_logout(s->pid, s->tty, s->pw->pw_name); 718 record_logout(s->pid, s->tty, s->pw->pw_name);
719diff --git a/session.h b/session.h 719diff --git a/session.h b/session.h
720index cb4f196..7e51b6a 100644 720index ef6593c..a6b6983 100644
721--- a/session.h 721--- a/session.h
722+++ b/session.h 722+++ b/session.h
723@@ -26,6 +26,8 @@ 723@@ -26,6 +26,8 @@
@@ -729,7 +729,7 @@ index cb4f196..7e51b6a 100644
729 #define TTYSZ 64 729 #define TTYSZ 64
730 typedef struct Session Session; 730 typedef struct Session Session;
731 struct Session { 731 struct Session {
732@@ -60,6 +62,10 @@ struct Session { 732@@ -61,6 +63,10 @@ struct Session {
733 char *name; 733 char *name;
734 char *val; 734 char *val;
735 } *env; 735 } *env;