summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules102
1 files changed, 72 insertions, 30 deletions
diff --git a/debian/rules b/debian/rules
index d088d2701..0d85abbf3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -100,7 +100,8 @@ ifeq ($(PO2DEBCONF),yes)
100 # 4.1.16) depends on it), the binary-arch target will generate a 100 # 4.1.16) depends on it), the binary-arch target will generate a
101 # better version for sarge. 101 # better version for sarge.
102 echo 1 > debian/po/output 102 echo 1 > debian/po/output
103 po2debconf debian/templates.master > debian/templates 103 po2debconf debian/openssh-client.templates.master > debian/openssh-client.templates
104 po2debconf debian/openssh-server.templates.master > debian/openssh-server.templates
104 rm -f debian/po/output 105 rm -f debian/po/output
105endif 106endif
106ifeq ($(PAMSUBST),yes) 107ifeq ($(PAMSUBST),yes)
@@ -118,16 +119,23 @@ install: build
118 dh_clean -k 119 dh_clean -k
119 dh_installdirs 120 dh_installdirs
120 121
121 # Add here commands to install the package into debian/ssh. 122 $(MAKE) -C build-deb DESTDIR=`pwd`/debian/openssh-client install-nokeys
122 $(MAKE) -C build-deb DESTDIR=`pwd`/debian/ssh install-nokeys
123 123
124 rm -f debian/ssh/etc/ssh/sshd_config 124 rm -f debian/openssh-client/etc/ssh/sshd_config
125 #Temporary hack: remove /usr/share/Ssh.bin, since we have no smartcard support anyway. 125 #Temporary hack: remove /usr/share/Ssh.bin, since we have no smartcard support anyway.
126 rm -f debian/ssh/usr/share/Ssh.bin 126 rm -f debian/openssh-client/usr/share/Ssh.bin
127 127
128 install -m 755 contrib/ssh-copy-id debian/ssh/usr/bin/ssh-copy-id 128 # Split off the server.
129 install -m 644 -c contrib/ssh-copy-id.1 debian/ssh/usr/share/man/man1/ssh-copy-id.1 129 mv debian/openssh-client/usr/sbin/sshd debian/openssh-server/usr/sbin/
130 install -m 644 debian/moduli.5 debian/ssh/usr/share/man/man5/moduli.5 130 mv debian/openssh-client/usr/lib/sftp-server debian/openssh-server/usr/lib/
131 mv debian/openssh-client/usr/share/man/man5/sshd_config.5 debian/openssh-server/usr/share/man/man5/
132 mv debian/openssh-client/usr/share/man/man8/sshd.8 debian/openssh-server/usr/share/man/man8/
133 mv debian/openssh-client/usr/share/man/man8/sftp-server.8 debian/openssh-server/usr/share/man/man8/
134 rmdir debian/openssh-client/var/run/sshd
135
136 install -m 755 contrib/ssh-copy-id debian/openssh-client/usr/bin/ssh-copy-id
137 install -m 644 -c contrib/ssh-copy-id.1 debian/openssh-client/usr/share/man/man1/ssh-copy-id.1
138 install -m 644 debian/moduli.5 debian/openssh-client/usr/share/man/man5/moduli.5
131 139
132 if [ -f contrib/gnome-ssh-askpass2 ]; then \ 140 if [ -f contrib/gnome-ssh-askpass2 ]; then \
133 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \ 141 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \
@@ -135,16 +143,13 @@ install: build
135 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \ 143 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \
136 fi 144 fi
137 install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1 145 install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1
138 install -m 644 debian/ssh-askpass-gnome.desktop debian/ssh-askpass-gnome/usr/share/applications/ssh-askpass-gnome.desktop
139 uudecode -o debian/ssh-askpass-gnome/usr/share/pixmaps/ssh-askpass-gnome.png debian/ssh-askpass-gnome.png.uue 146 uudecode -o debian/ssh-askpass-gnome/usr/share/pixmaps/ssh-askpass-gnome.png debian/ssh-askpass-gnome.png.uue
140 147
141 install -m 755 debian/ssh-argv0 debian/ssh/usr/bin/ssh-argv0 148 install -m 755 debian/ssh-argv0 debian/openssh-client/usr/bin/ssh-argv0
142 install -m 644 debian/ssh-argv0.1 debian/ssh/usr/share/man/man1/ssh-argv0.1 149 install -m 644 debian/ssh-argv0.1 debian/openssh-client/usr/share/man/man1/ssh-argv0.1
143
144 install -o root -g root debian/init debian/ssh/etc/init.d/ssh
145 install -o root -g root -m 644 debian/ssh.default debian/ssh/etc/default/ssh
146 150
147 install -o root -g root -m 755 -d debian/ssh/var/run/sshd 151 install -o root -g root debian/openssh-server.init debian/openssh-server/etc/init.d/ssh
152 install -o root -g root -m 644 debian/openssh-server.default debian/openssh-server/etc/default/ssh
148 153
149 install -m 755 build-udeb/ssh debian/openssh-client-udeb/usr/bin/ssh 154 install -m 755 build-udeb/ssh debian/openssh-client-udeb/usr/bin/ssh
150 install -m 755 build-udeb/scp debian/openssh-client-udeb/usr/bin/scp 155 install -m 755 build-udeb/scp debian/openssh-client-udeb/usr/bin/scp
@@ -153,54 +158,89 @@ install: build
153 install -m 755 build-udeb/ssh-keygen debian/openssh-server-udeb/usr/bin/ssh-keygen 158 install -m 755 build-udeb/ssh-keygen debian/openssh-server-udeb/usr/bin/ssh-keygen
154 159
155# Build architecture-independent files here. 160# Build architecture-independent files here.
156binary-indep: build install 161binary-indep: binary-ssh
157 # nothing to do
158 162
159# Build architecture-dependent files here. 163# Build architecture-dependent files here.
160binary-arch: binary-ssh binary-ssh-askpass-gnome 164binary-arch: binary-openssh-client binary-openssh-server
165binary-arch: binary-ssh-askpass-gnome
161binary-arch: binary-openssh-client-udeb binary-openssh-server-udeb 166binary-arch: binary-openssh-client-udeb binary-openssh-server-udeb
162 167
163binary-ssh: DH_OPTIONS=-pssh 168binary-openssh-client: DH_OPTIONS=-popenssh-client
164binary-ssh: build install 169binary-openssh-client: build install
165 dh_testdir 170 dh_testdir
166 dh_testroot 171 dh_testroot
167ifeq ($(PO2DEBCONF),yes) 172ifeq ($(PO2DEBCONF),yes)
168 po2debconf -e utf8 debian/templates.master > debian/templates 173 po2debconf -e utf8 debian/openssh-client.templates.master > debian/openssh-client.templates
169endif 174endif
170 dh_installdebconf 175 dh_installdebconf
171 dh_installdocs OVERVIEW README 176 dh_installdocs OVERVIEW README
172 cat debian/copyright.head LICENCE > debian/ssh/usr/share/doc/ssh/copyright 177 cat debian/copyright.head LICENCE > debian/openssh-client/usr/share/doc/openssh-client/copyright
178 dh_installchangelogs ChangeLog
179 dh_strip
180 dh_compress
181 dh_fixperms
182 dh_installdeb
183 test ! -e debian/ssh/etc/ssh/ssh_prng_cmds \
184 || echo "/etc/ssh/ssh_prng_cmds" >> debian/openssh-client/DEBIAN/conffiles
185 dh_shlibdeps
186 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER))'
187 dh_md5sums
188 dh_builddeb
189
190binary-openssh-server: DH_OPTIONS=-popenssh-server
191binary-openssh-server: build install
192 dh_testdir
193 dh_testroot
194ifeq ($(PO2DEBCONF),yes)
195 po2debconf -e utf8 debian/openssh-server.templates.master > debian/openssh-server.templates
196endif
197 dh_installdebconf
198 dh_installdocs OVERVIEW README
199 cat debian/copyright.head LICENCE > debian/openssh-server/usr/share/doc/openssh-server/copyright
173ifeq ($(PAMSUBST),yes) 200ifeq ($(PAMSUBST),yes)
174 # Clean up if we've done this already, to ensure idempotency. 201 # Clean up if we've done this already, to ensure idempotency.
175 if [ -f debian/ssh.pam.new-style ]; then \ 202 if [ -f debian/openssh-server.ssh.pam.new-style ]; then \
176 mv debian/ssh.pam.new-style debian/ssh.pam; \ 203 mv debian/openssh-server.ssh.pam.new-style debian/openssh-server.ssh.pam; \
177 fi 204 fi
178 cp -a debian/ssh.pam debian/ssh.pam.new-style 205 cp -a debian/openssh-server.ssh.pam debian/openssh-server.ssh.pam.new-style
179 sed -e "s/@include common-auth/auth required pam_unix.so/" \ 206 sed -e "s/@include common-auth/auth required pam_unix.so/" \
180 -e "s/@include common-account/account required pam_unix.so/" \ 207 -e "s/@include common-account/account required pam_unix.so/" \
181 -e "s/@include common-session/session required pam_unix.so/" \ 208 -e "s/@include common-session/session required pam_unix.so/" \
182 -e "s/@include common-password/password required pam_unix.so/" \ 209 -e "s/@include common-password/password required pam_unix.so/" \
183 debian/ssh.pam.new-style > debian/ssh.pam 210 debian/openssh-server.ssh.pam.new-style > debian/openssh-server.ssh.pam
184endif 211endif
185 dh_installpam 212 dh_installpam --name ssh # TODO: breaks woody backports
186 dh_installchangelogs ChangeLog 213 dh_installchangelogs ChangeLog
187 dh_strip 214 dh_strip
188 dh_compress 215 dh_compress
189 dh_fixperms 216 dh_fixperms
190 dh_installdeb 217 dh_installdeb
191 test ! -e debian/ssh/etc/ssh/ssh_prng_cmds \
192 || echo "/etc/ssh/ssh_prng_cmds" >> debian/ssh/DEBIAN/conffiles
193 dh_shlibdeps 218 dh_shlibdeps
194 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER))' \ 219 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER))' \
195 -V'pam-depends=$(PAMDEP)' 220 -V'pam-depends=$(PAMDEP)'
196 dh_md5sums 221 dh_md5sums
197 dh_builddeb 222 dh_builddeb
198 223
224binary-ssh: DH_OPTIONS=-pssh
225binary-ssh: build install
226 dh_testdir
227 dh_testroot
228 dh_installdocs
229 cat debian/copyright.head LICENCE > debian/ssh/usr/share/doc/ssh/copyright
230 dh_installchangelogs
231 dh_compress
232 dh_fixperms
233 dh_installdeb
234 dh_gencontrol
235 dh_md5sums
236 dh_builddeb
237
199binary-ssh-askpass-gnome: DH_OPTIONS=-pssh-askpass-gnome 238binary-ssh-askpass-gnome: DH_OPTIONS=-pssh-askpass-gnome
200binary-ssh-askpass-gnome: build install 239binary-ssh-askpass-gnome: build install
201 dh_testdir 240 dh_testdir
202 dh_testroot 241 dh_testroot
203 dh_installdocs 242 dh_installdocs
243 dh_installexamples debian/ssh-askpass-gnome.desktop
204 dh_installchangelogs ChangeLog 244 dh_installchangelogs ChangeLog
205 dh_strip 245 dh_strip
206 dh_compress 246 dh_compress
@@ -241,5 +281,7 @@ binary-openssh-server-udeb: build install
241binary: binary-indep binary-arch 281binary: binary-indep binary-arch
242 282
243.PHONY: build clean binary-indep binary-arch binary install 283.PHONY: build clean binary-indep binary-arch binary install
244.PHONY: build-deb build-udeb binary-ssh binary-ssh-askpass-gnome 284.PHONY: build-deb build-udeb
285.PHONY: binary-openssh-client binary-openssh-server binary-ssh
286.PHONY: binary-ssh-askpass-gnome
245.PHONY: binary-openssh-client-udeb binary-openssh-server-udeb 287.PHONY: binary-openssh-client-udeb binary-openssh-server-udeb