summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog17
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/ssh.default3
3 files changed, 20 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index e5f2004eb..532567f8d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,20 @@
1openssh (1:3.6p1-1) unstable; urgency=low
2
3 * New upstream release.
4 - Workaround applied upstream for a bug in the interaction of glibc's
5 getaddrinfo() with the Linux 2.2 kernel (closes: #155814).
6 - As such, it should now be safe to remove --with-ipv4-default, so
7 starting sshd with -6 is no longer necessary (closes: #79861 and lots
8 of other merged bugs).
9 - ssh-copy-id prints usage when run without arguments (closes: #71376).
10 - scp exits 1 if ssh fails (closes: #138400).
11 - sshd writes to utmp's ut_addr_v6 field in IPv6 mode (closes: #167867).
12 - 'ssh-add -c' causes ssh-agent to ask the user each time a key is used
13 (closes: #109795).
14 * Install /etc/default/ssh non-executable (closes: #185537).
15
16 -- Colin Watson <cjwatson@debian.org> Mon, 31 Mar 2003 23:00:59 +0100
17
1openssh (1:3.5p1-5) unstable; urgency=low 18openssh (1:3.5p1-5) unstable; urgency=low
2 19
3 * Add /etc/default/ssh (closes: #161049). 20 * Add /etc/default/ssh (closes: #161049).
diff --git a/debian/rules b/debian/rules
index 5b91fdde7..dcf406f24 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,7 +19,7 @@ build-stamp:
19 then mv version.h version.h.upstream; mv version.h.new version.h; \ 19 then mv version.h version.h.upstream; mv version.h.new version.h; \
20 else echo "Version number change failed"; exit 1; \ 20 else echo "Version number change failed"; exit 1; \
21 fi 21 fi
22 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-ipv4-default \ 22 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 \
23 --with-privsep-path=/var/run/sshd --without-rand-helper 23 --with-privsep-path=/var/run/sshd --without-rand-helper
24 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ 24 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \
25 SSH_KEYSIGN='/usr/lib/ssh-keysign' 25 SSH_KEYSIGN='/usr/lib/ssh-keysign'
@@ -70,7 +70,7 @@ install: build
70 install -m 644 debian/ssh-argv0.1 debian/tmp/usr/share/man/man1/ssh-argv0.1 70 install -m 644 debian/ssh-argv0.1 debian/tmp/usr/share/man/man1/ssh-argv0.1
71 71
72 install -o root -g root debian/init debian/tmp/etc/init.d/ssh 72 install -o root -g root debian/init debian/tmp/etc/init.d/ssh
73 install -o root -g root debian/ssh.default debian/tmp/etc/default/ssh 73 install -o root -g root -m 644 debian/ssh.default debian/tmp/etc/default/ssh
74 74
75 install -o root -g root -m 755 -d debian/tmp/var/run/sshd 75 install -o root -g root -m 755 -d debian/tmp/var/run/sshd
76 76
diff --git a/debian/ssh.default b/debian/ssh.default
index 15305579b..aa03c4e07 100644
--- a/debian/ssh.default
+++ b/debian/ssh.default
@@ -1,5 +1,4 @@
1#! /bin/sh 1# Default settings for ssh. This file is sourced by /bin/sh from
2# Default settings for ssh. This file is sourced by the shell from
3# /etc/init.d/ssh. 2# /etc/init.d/ssh.
4 3
5# Options to pass to sshd 4# Options to pass to sshd