summaryrefslogtreecommitdiff
path: root/openssh.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openssh.spec')
-rw-r--r--openssh.spec59
1 files changed, 52 insertions, 7 deletions
diff --git a/openssh.spec b/openssh.spec
index 888908a51..6b81b2724 100644
--- a/openssh.spec
+++ b/openssh.spec
@@ -8,6 +8,16 @@ Copyright: BSD
8Group: Applications/Internet 8Group: Applications/Internet
9BuildRoot: /tmp/openssh-%{version}-buildroot 9BuildRoot: /tmp/openssh-%{version}-buildroot
10 10
11%package server
12Summary: Secure Shell protocol server (sshd)
13Requires: openssh chkconfig >= 0.9
14Group: System Environment/Daemons
15
16%package askpass
17Summary: GNOME passphrase dialog
18Group: Applications/Internet
19Requires: openssh
20
11%description 21%description
12Ssh (Secure Shell) a program for logging into a remote machine and for 22Ssh (Secure Shell) a program for logging into a remote machine and for
13executing commands in a remote machine. It is intended to replace 23executing commands in a remote machine. It is intended to replace
@@ -19,9 +29,41 @@ OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
19up to date in terms of security and features, as well as removing all 29up to date in terms of security and features, as well as removing all
20patented algorithms to seperate libraries (OpenSSL). 30patented algorithms to seperate libraries (OpenSSL).
21 31
32This package includes the clients necessary to make encrypted connections
33to SSH servers.
34
35%description server
36Ssh (Secure Shell) a program for logging into a remote machine and for
37executing commands in a remote machine. It is intended to replace
38rlogin and rsh, and provide secure encrypted communications between
39two untrusted hosts over an insecure network. X11 connections and
40arbitrary TCP/IP ports can also be forwarded over the secure channel.
41
42OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
43up to date in terms of security and features, as well as removing all
44patented algorithms to seperate libraries (OpenSSL).
45
46This package contains the secure shell daemon and its documentation.
47The sshd is the server part of the secure shell protocol and allows
48ssh clients to connect to your host.
49
50%description askpass
51Ssh (Secure Shell) a program for logging into a remote machine and for
52executing commands in a remote machine. It is intended to replace
53rlogin and rsh, and provide secure encrypted communications between
54two untrusted hosts over an insecure network. X11 connections and
55arbitrary TCP/IP ports can also be forwarded over the secure channel.
56
57OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
58up to date in terms of security and features, as well as removing all
59patented algorithms to seperate libraries (OpenSSL).
60
61This package contains the GNOME passphrase dialog.
62
22%changelog 63%changelog
23* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au> 64* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
24- Use make install 65- Use make install
66- Subpackages
25* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au> 67* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
26- Added links for slogin 68- Added links for slogin
27- Fixed perms on manpages 69- Fixed perms on manpages
@@ -61,7 +103,7 @@ install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
61%clean 103%clean
62rm -rf $RPM_BUILD_ROOT 104rm -rf $RPM_BUILD_ROOT
63 105
64%post 106%post server
65/sbin/chkconfig --add sshd 107/sbin/chkconfig --add sshd
66if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then 108if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
67 /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2 109 /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
@@ -71,7 +113,7 @@ then
71 /etc/rc.d/init.d/sshd restart >&2 113 /etc/rc.d/init.d/sshd restart >&2
72fi 114fi
73 115
74%preun 116%preun server
75if [ "$1" = 0 ] 117if [ "$1" = 0 ]
76then 118then
77 /etc/rc.d/init.d/sshd stop >&2 119 /etc/rc.d/init.d/sshd stop >&2
@@ -82,25 +124,28 @@ fi
82%defattr(-,root,root) 124%defattr(-,root,root)
83%doc COPYING.Ylonen ChangeLog ChangeLog.Ylonen OVERVIEW 125%doc COPYING.Ylonen ChangeLog ChangeLog.Ylonen OVERVIEW
84%doc README README.Ylonen 126%doc README README.Ylonen
85%attr(0755,root,root) /usr/sbin/sshd
86%attr(0755,root,root) /usr/bin/ssh 127%attr(0755,root,root) /usr/bin/ssh
87%attr(0755,root,root) /usr/bin/ssh-agent 128%attr(0755,root,root) /usr/bin/ssh-agent
88%attr(0755,root,root) /usr/bin/ssh-keygen 129%attr(0755,root,root) /usr/bin/ssh-keygen
89%attr(0755,root,root) /usr/bin/ssh-add 130%attr(0755,root,root) /usr/bin/ssh-add
90%attr(0755,root,root) /usr/bin/scp 131%attr(0755,root,root) /usr/bin/scp
91%attr(0755,root,root) /usr/bin/slogin 132%attr(0755,root,root) /usr/bin/slogin
92%attr(0755,root,root) /usr/lib/ssh/ssh-askpass
93
94%attr(0644,root,root) /usr/man/man8/sshd.8
95%attr(0644,root,root) /usr/man/man1/ssh.1 133%attr(0644,root,root) /usr/man/man1/ssh.1
96%attr(0644,root,root) /usr/man/man1/ssh-agent.1 134%attr(0644,root,root) /usr/man/man1/ssh-agent.1
97%attr(0644,root,root) /usr/man/man1/ssh-keygen.1 135%attr(0644,root,root) /usr/man/man1/ssh-keygen.1
98%attr(0644,root,root) /usr/man/man1/ssh-add.1 136%attr(0644,root,root) /usr/man/man1/ssh-add.1
99%attr(0644,root,root) /usr/man/man1/scp.1 137%attr(0644,root,root) /usr/man/man1/scp.1
100%attr(0644,root,root) /usr/man/man1/slogin.1 138%attr(0644,root,root) /usr/man/man1/slogin.1
139%attr(0644,root,root) %config /etc/ssh/ssh_config
101 140
141%files server
142%defattr(-,root,root)
143%attr(0755,root,root) /usr/sbin/sshd
144%attr(0644,root,root) /usr/man/man8/sshd.8
102%attr(0600,root,root) %config /etc/ssh/sshd_config 145%attr(0600,root,root) %config /etc/ssh/sshd_config
103%attr(0600,root,root) %config /etc/pam.d/sshd 146%attr(0600,root,root) %config /etc/pam.d/sshd
104%attr(0755,root,root) %config /etc/rc.d/init.d/sshd 147%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
105%attr(0644,root,root) %config /etc/ssh/ssh_config
106 148
149%files askpass
150%defattr(-,root,root)
151%attr(0755,root,root) /usr/lib/ssh/ssh-askpass