summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhugbubby <hugbubby@protonmail.com>2018-07-15 20:55:45 -0700
committeriphydf <iphydf@users.noreply.github.com>2018-07-23 15:10:22 +0000
commitc4d58403f966328fb26e062b71adf05842ff3039 (patch)
tree6fd8129885666eac4595036b424c6b2e9a8439dc /CMakeLists.txt
parentf627a26a7b1c3619ba66f84b87092ff8ba7a95b6 (diff)
More fixed_width ints and incorporating file_saving_test.c
The file_saving_test.c was not included in the cmake list and thus was ignored by travis and "make check". I found this out while introducing ck_assert_msg into the integration test. Furthermore, removed some variable width integers from encryptsave_test.c, and the SRunner utilization. Implemmented ck_assert_msg, reorganized some loops, and removed some longs in file_transfer_test.c.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92c7beb9..f025ac72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -414,6 +414,7 @@ auto_test(crypto MSVC_DONT_BUILD)
414auto_test(dht MSVC_DONT_BUILD) 414auto_test(dht MSVC_DONT_BUILD)
415auto_test(encryptsave) 415auto_test(encryptsave)
416auto_test(file_transfer) 416auto_test(file_transfer)
417auto_test(file_saving)
417auto_test(friend_connection) 418auto_test(friend_connection)
418auto_test(friend_request) 419auto_test(friend_request)
419auto_test(invalid_proxy) 420auto_test(invalid_proxy)