summaryrefslogtreecommitdiff
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorirungentoo <irungentoo@gmail.com>2013-07-22 04:09:45 -0700
committerirungentoo <irungentoo@gmail.com>2013-07-22 04:09:45 -0700
commit11891e2475a123ad911647e380d2c547db70de09 (patch)
tree73ebc7ec31fb707cdd75df18323f3d98337afe61 /core/CMakeLists.txt
parentb7393890eb8fd3505c2f71a37f4756f71f948890 (diff)
parent2ab2ebe5a5f47b53a026118f144adf932aad1f11 (diff)
Merge pull request #84 from nurupo/master
Improved build system
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
new file mode 100644
index 00000000..51f30e17
--- /dev/null
+++ b/core/CMakeLists.txt
@@ -0,0 +1,15 @@
1cmake_minimum_required(VERSION 2.6.0)
2project(core C)
3
4if(WIN32)
5 include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/)
6endif()
7
8set(core_sources
9 DHT.c
10 network.c
11 Lossless_UDP.c
12 net_crypto.c
13 Messenger.c)
14
15add_library(core ${core_sources})