diff options
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r-- | core/CMakeLists.txt | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt new file mode 100644 index 00000000..51f30e17 --- /dev/null +++ b/core/CMakeLists.txt | |||
@@ -0,0 +1,15 @@ | |||
1 | cmake_minimum_required(VERSION 2.6.0) | ||
2 | project(core C) | ||
3 | |||
4 | if(WIN32) | ||
5 | include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/) | ||
6 | endif() | ||
7 | |||
8 | set(core_sources | ||
9 | DHT.c | ||
10 | network.c | ||
11 | Lossless_UDP.c | ||
12 | net_crypto.c | ||
13 | Messenger.c) | ||
14 | |||
15 | add_library(core ${core_sources}) | ||