summaryrefslogtreecommitdiff
path: root/other/CMakeLists.txt
diff options
context:
space:
mode:
authorSean Qureshi <stqism@risingstormgames.com>2013-08-18 03:41:30 -0700
committerSean Qureshi <stqism@risingstormgames.com>2013-08-18 03:41:30 -0700
commitbdfd890aa835d6601003541bce722c607e90cc6b (patch)
tree0ec3caa5196a13a70e547fd33129c0170744a55d /other/CMakeLists.txt
parentc3d90c67640b72a57007d0f6261a5a30ed079be2 (diff)
Added mac support to the standardized data file, cleaned up a bit
Diffstat (limited to 'other/CMakeLists.txt')
-rw-r--r--other/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/other/CMakeLists.txt b/other/CMakeLists.txt
index 068f83db..22867773 100644
--- a/other/CMakeLists.txt
+++ b/other/CMakeLists.txt
@@ -9,8 +9,13 @@ if(WIN32)
9 file(INSTALL DHTservers DESTINATION %appdata%/.tox) 9 file(INSTALL DHTservers DESTINATION %appdata%/.tox)
10else() 10else()
11 set(HOME "$ENV{HOME}") 11 set(HOME "$ENV{HOME}")
12 file(MAKE_DIRECTORY ${HOME}/.tox) 12 if(APPLE)
13 file(INSTALL DHTservers DESTINATION ${HOME}/.tox) 13 file(MAKE_DIRECTORY ${HOME}Library/Application Support/.tox)
14 file(INSTALL DHTservers DESTINATION ${HOME}Library/Application Support/.tox)
15 else()
16 file(MAKE_DIRECTORY ${HOME}/.tox)
17 file(INSTALL DHTservers DESTINATION ${HOME}/.tox)
18 endif()
14endif() 19endif()
15 20
16if(LINUX) 21if(LINUX)