summaryrefslogtreecommitdiff
path: root/other/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'other/CMakeLists.txt')
-rw-r--r--other/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/other/CMakeLists.txt b/other/CMakeLists.txt
index 068f83db..22867773 100644
--- a/other/CMakeLists.txt
+++ b/other/CMakeLists.txt
@@ -9,8 +9,13 @@ if(WIN32)
9 file(INSTALL DHTservers DESTINATION %appdata%/.tox) 9 file(INSTALL DHTservers DESTINATION %appdata%/.tox)
10else() 10else()
11 set(HOME "$ENV{HOME}") 11 set(HOME "$ENV{HOME}")
12 file(MAKE_DIRECTORY ${HOME}/.tox) 12 if(APPLE)
13 file(INSTALL DHTservers DESTINATION ${HOME}/.tox) 13 file(MAKE_DIRECTORY ${HOME}Library/Application Support/.tox)
14 file(INSTALL DHTservers DESTINATION ${HOME}Library/Application Support/.tox)
15 else()
16 file(MAKE_DIRECTORY ${HOME}/.tox)
17 file(INSTALL DHTservers DESTINATION ${HOME}/.tox)
18 endif()
14endif() 19endif()
15 20
16if(LINUX) 21if(LINUX)