summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBen West <bewest@gmail.com>2015-05-14 19:56:02 -0700
committerBen West <bewest@gmail.com>2015-05-14 19:56:02 -0700
commit5ba0227d61ca4fef588eaed62c0ab3578b4bf6f9 (patch)
tree9b0dda162e7edc1f8366644cb349e5663c11d507 /setup.py
parenta719be3f4dffc11d266bbf03309f3ea6eb23ac88 (diff)
don't try to install in system location at all now
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 10a729d..88437da 100644
--- a/setup.py
+++ b/setup.py
@@ -9,10 +9,8 @@ def is_virtualenv ( ):
9 import os, os.path 9 import os, os.path
10 proc = subprocess.Popen(['which', 'add2virtualenv'], stderr=subprocess.PIPE, stdout=subprocess.PIPE) 10 proc = subprocess.Popen(['which', 'add2virtualenv'], stderr=subprocess.PIPE, stdout=subprocess.PIPE)
11 shell = os.path.dirname(sys.argv[0]) 11 shell = os.path.dirname(sys.argv[0])
12 proc.communicate( )
12 has_venv = proc.poll( ) == 0 13 has_venv = proc.poll( ) == 0
13 print "shell root shares project root", shell, os.path.dirname(__file__)
14 print 'huh', sys.argv, has_venv, os.environ, __file__
15 print 'real_prefix', getattr(sys, 'real_prefix', '??')
16 print "RESULT", proc.poll( ), has_venv, os.environ.get('VIRTUAL_ENV') 14 print "RESULT", proc.poll( ), has_venv, os.environ.get('VIRTUAL_ENV')
17 return os.environ.get('VIRTUAL_ENV', has_venv) 15 return os.environ.get('VIRTUAL_ENV', has_venv)
18 16
@@ -23,7 +21,7 @@ def readme():
23 21
24dataFiles = [ ] 22dataFiles = [ ]
25if platform.system( ) == 'Linux': 23if platform.system( ) == 'Linux':
26 prefix = '/' 24 # prefix = '/'
27 dataFiles = [ 25 dataFiles = [
28 (prefix + 'etc/udev/rules.d', ['etc/udev/rules.d/80-dexcom.rules']), 26 (prefix + 'etc/udev/rules.d', ['etc/udev/rules.d/80-dexcom.rules']),
29 ] 27 ]