summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authoridontgetoutmuch <dominic@steinitz.org>2018-03-26 10:32:51 +0100
committerGitHub <noreply@github.com>2018-03-26 10:32:51 +0100
commit9fd7adf7dda75077b85f0337a548be9138fc1ed5 (patch)
tree03e23b7027dd1e7983a98328b47aa795256005de /shell.nix
parent560f38ab27bcc44c80ce7d9c2e4972342170fe28 (diff)
Revert "Cleanups to Sundials PR"
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index c034dde..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,20 +0,0 @@
1{ghc}:
2
3with import <nixpkgs> {};
4
5let
6 gfortranlibdir = "${gfortran7.cc.lib}";
7 # XXX Workaround https://ghc.haskell.org/trac/ghc/ticket/11042.
8 libHack = if stdenv.isDarwin then {
9 DYLD_LIBRARY_PATH = [gfortranlibdir];
10 } else {
11 LD_LIBRARY_PATH = [gfortranlibdir];
12 };
13in
14haskell.lib.buildStackProject ({
15 name = "haskell-sundials";
16 buildInputs = [blas liblapack sundials zlib];
17 inherit ghc;
18 # XXX Workaround https://ghc.haskell.org/trac/ghc/ticket/11042.
19 extraArgs = ["--extra-lib-dirs=${gfortranlibdir}"];
20} // libHack)