summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authoridontgetoutmuch <dominic@steinitz.org>2018-04-22 03:17:40 -0700
committerGitHub <noreply@github.com>2018-04-22 03:17:40 -0700
commitdf9980a1bc95cbe96b6766dc232c4abc8ca28c38 (patch)
tree72eae1364abfd4ef4b022f94cb126c189f5cde85 /shell.nix
parent94db29b5d25f28708c1d430554f0c337c26172df (diff)
parent492b7e13c47bc7e42583c6a1754bdb2bb445b94f (diff)
Merge pull request #264 from idontgetoutmuch/sundials-clean
Add Sundials as an ODE Engine
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..42bbe08
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,26 @@
1{ nixpkgs ? import <nixpkgs> {} }:
2let p = nixpkgs; in
3
4 let
5 myStack = p.writeShellScriptBin "stack" ''
6 exec ${p.stack}/bin/stack --no-nix --no-docker --system-ghc $STACK_IN_NIX_EXTRA_ARGS "$@"
7 '';
8in
9p.haskell.lib.buildStackProject {
10 name = "hmatrix";
11
12 buildInputs = [
13 p.zlib
14 p.sundials
15 p.blas
16 p.gfortran.cc
17 p.liblapack
18 p.gsl
19 p.glpk
20 p.pkgconfig
21 p.stack
22 p.sundials
23 myStack
24 ] ++ (if p.stdenv.isDarwin then [p.darwin.apple_sdk.frameworks.Accelerate] else [])
25 ++ (if p.stdenv.isDarwin then [p.darwin.apple_sdk.frameworks.Cocoa] else []);
26}