summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2020-09-20 17:48:15 +0100
committerColin Watson <cjwatson@debian.org>2020-09-20 17:48:15 +0100
commit05fa6dd7724ccfd1c183e6e4bf9d22eb12abea8c (patch)
tree71d3eccc33c93c230b021c72f1fb9cf2247bf6c0 /tools/CMakeLists.txt
parentb77d6ed4d47acbc836f05be0e9f4abeb104e21ff (diff)
parent173bfbf7886608a4a7abbfac6a42ac4bf4a3432d (diff)
Update upstream source from tag 'upstream/1.5.0'
Update to upstream version '1.5.0' with Debian dir 102fd7ed15b138200444754d256b136933185ec2
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 274a799..4d08be9 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -20,6 +20,13 @@ else()
20 list(APPEND COMPAT_SOURCES ../openbsd-compat/readpassphrase.c) 20 list(APPEND COMPAT_SOURCES ../openbsd-compat/readpassphrase.c)
21endif() 21endif()
22 22
23if(NOT MSVC)
24 set_source_files_properties(assert_get.c assert_verify.c base64.c bio.c
25 cred_make.c cred_verify.c credman.c fido2-assert.c fido2-cred.c
26 fido2-token.c pin.c token.c util.c PROPERTIES COMPILE_FLAGS
27 "-Wconversion -Wsign-conversion")
28endif()
29
23add_executable(fido2-cred 30add_executable(fido2-cred
24 fido2-cred.c 31 fido2-cred.c
25 cred_make.c 32 cred_make.c