summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2015-08-19 16:33:29 +0100
commit06879e71614170580ffa7568ec5c009f60a9d084 (patch)
tree2264e498417b1968891c6f8a3c3b560b2b3a4761 /configure.ac
parentbaccdb349b31c47cd76fb63211f754ed33a9707e (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2015-08-19 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b4d6598d5..216a9fdab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -620,6 +620,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
620 [Use tunnel device compatibility to OpenBSD]) 620 [Use tunnel device compatibility to OpenBSD])
621 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 621 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
622 [Prepend the address family to IP tunnel traffic]) 622 [Prepend the address family to IP tunnel traffic])
623 AC_MSG_CHECKING([if we have the Security Authorization Session API])
624 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
625 [SessionCreate(0, 0);],
626 [ac_cv_use_security_session_api="yes"
627 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
628 [platform has the Security Authorization Session API])
629 LIBS="$LIBS -framework Security"
630 AC_MSG_RESULT([yes])],
631 [ac_cv_use_security_session_api="no"
632 AC_MSG_RESULT([no])])
633 AC_MSG_CHECKING([if we have an in-memory credentials cache])
634 AC_TRY_COMPILE(
635 [#include <Kerberos/Kerberos.h>],
636 [cc_context_t c;
637 (void) cc_initialize (&c, 0, NULL, NULL);],
638 [AC_DEFINE([USE_CCAPI], [1],
639 [platform uses an in-memory credentials cache])
640 LIBS="$LIBS -framework Security"
641 AC_MSG_RESULT([yes])
642 if test "x$ac_cv_use_security_session_api" = "xno"; then
643 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
644 fi],
645 [AC_MSG_RESULT([no])]
646 )
623 m4_pattern_allow([AU_IPv]) 647 m4_pattern_allow([AU_IPv])
624 AC_CHECK_DECL([AU_IPv4], [], 648 AC_CHECK_DECL([AU_IPv4], [],
625 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 649 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])