summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b4d6598d5..216a9fdab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -620,6 +620,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
620 [Use tunnel device compatibility to OpenBSD]) 620 [Use tunnel device compatibility to OpenBSD])
621 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 621 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
622 [Prepend the address family to IP tunnel traffic]) 622 [Prepend the address family to IP tunnel traffic])
623 AC_MSG_CHECKING([if we have the Security Authorization Session API])
624 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
625 [SessionCreate(0, 0);],
626 [ac_cv_use_security_session_api="yes"
627 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
628 [platform has the Security Authorization Session API])
629 LIBS="$LIBS -framework Security"
630 AC_MSG_RESULT([yes])],
631 [ac_cv_use_security_session_api="no"
632 AC_MSG_RESULT([no])])
633 AC_MSG_CHECKING([if we have an in-memory credentials cache])
634 AC_TRY_COMPILE(
635 [#include <Kerberos/Kerberos.h>],
636 [cc_context_t c;
637 (void) cc_initialize (&c, 0, NULL, NULL);],
638 [AC_DEFINE([USE_CCAPI], [1],
639 [platform uses an in-memory credentials cache])
640 LIBS="$LIBS -framework Security"
641 AC_MSG_RESULT([yes])
642 if test "x$ac_cv_use_security_session_api" = "xno"; then
643 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
644 fi],
645 [AC_MSG_RESULT([no])]
646 )
623 m4_pattern_allow([AU_IPv]) 647 m4_pattern_allow([AU_IPv])
624 AC_CHECK_DECL([AU_IPv4], [], 648 AC_CHECK_DECL([AU_IPv4], [],
625 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 649 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])