summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2019-06-05 07:06:44 +0100
commit7ce79be85036c4b36937f1b1ba85f6094068412c (patch)
treec964917d8395ef5605cff9513aad4458b222beae /configure.ac
parent102062f825fb26a74295a1c089c00c4c4c76b68a (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Origin: other, https://github.com/openssh-gsskex/openssh-gsskex/commits/debian/master Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2019-06-05 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 30be6c182..2869f7042 100644
--- a/configure.ac
+++ b/configure.ac
@@ -665,6 +665,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
665 [Use tunnel device compatibility to OpenBSD]) 665 [Use tunnel device compatibility to OpenBSD])
666 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 666 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
667 [Prepend the address family to IP tunnel traffic]) 667 [Prepend the address family to IP tunnel traffic])
668 AC_MSG_CHECKING([if we have the Security Authorization Session API])
669 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
670 [SessionCreate(0, 0);],
671 [ac_cv_use_security_session_api="yes"
672 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
673 [platform has the Security Authorization Session API])
674 LIBS="$LIBS -framework Security"
675 AC_MSG_RESULT([yes])],
676 [ac_cv_use_security_session_api="no"
677 AC_MSG_RESULT([no])])
678 AC_MSG_CHECKING([if we have an in-memory credentials cache])
679 AC_TRY_COMPILE(
680 [#include <Kerberos/Kerberos.h>],
681 [cc_context_t c;
682 (void) cc_initialize (&c, 0, NULL, NULL);],
683 [AC_DEFINE([USE_CCAPI], [1],
684 [platform uses an in-memory credentials cache])
685 LIBS="$LIBS -framework Security"
686 AC_MSG_RESULT([yes])
687 if test "x$ac_cv_use_security_session_api" = "xno"; then
688 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
689 fi],
690 [AC_MSG_RESULT([no])]
691 )
668 m4_pattern_allow([AU_IPv]) 692 m4_pattern_allow([AU_IPv])
669 AC_CHECK_DECL([AU_IPv4], [], 693 AC_CHECK_DECL([AU_IPv4], [],
670 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 694 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])