summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2020-10-18 12:04:32 +0100
commitd1b7918f9bce6e997c7952ac795e18d09192b2a6 (patch)
tree897785ddb933a151a3d4b7f7d1b6542aee570b76 /configure.ac
parent2b2c99658e3e8ed452e28f88f9cdbcdfb2a461cb (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Author: Simon Wilkinson <simon@sxw.org.uk> Author: Colin Watson <cjwatson@debian.org> Author: Jakub Jelen <jjelen@redhat.com> Origin: other, https://github.com/openssh-gsskex/openssh-gsskex/commits/debian/master Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2020-06-07 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7005a503e..c8a96deb4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -679,6 +679,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
679 [Use tunnel device compatibility to OpenBSD]) 679 [Use tunnel device compatibility to OpenBSD])
680 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 680 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
681 [Prepend the address family to IP tunnel traffic]) 681 [Prepend the address family to IP tunnel traffic])
682 AC_MSG_CHECKING([if we have the Security Authorization Session API])
683 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
684 [SessionCreate(0, 0);],
685 [ac_cv_use_security_session_api="yes"
686 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
687 [platform has the Security Authorization Session API])
688 LIBS="$LIBS -framework Security"
689 AC_MSG_RESULT([yes])],
690 [ac_cv_use_security_session_api="no"
691 AC_MSG_RESULT([no])])
692 AC_MSG_CHECKING([if we have an in-memory credentials cache])
693 AC_TRY_COMPILE(
694 [#include <Kerberos/Kerberos.h>],
695 [cc_context_t c;
696 (void) cc_initialize (&c, 0, NULL, NULL);],
697 [AC_DEFINE([USE_CCAPI], [1],
698 [platform uses an in-memory credentials cache])
699 LIBS="$LIBS -framework Security"
700 AC_MSG_RESULT([yes])
701 if test "x$ac_cv_use_security_session_api" = "xno"; then
702 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
703 fi],
704 [AC_MSG_RESULT([no])]
705 )
682 m4_pattern_allow([AU_IPv]) 706 m4_pattern_allow([AU_IPv])
683 AC_CHECK_DECL([AU_IPv4], [], 707 AC_CHECK_DECL([AU_IPv4], [],
684 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 708 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])