summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7005a503e..c8a96deb4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -679,6 +679,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
679 [Use tunnel device compatibility to OpenBSD]) 679 [Use tunnel device compatibility to OpenBSD])
680 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 680 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
681 [Prepend the address family to IP tunnel traffic]) 681 [Prepend the address family to IP tunnel traffic])
682 AC_MSG_CHECKING([if we have the Security Authorization Session API])
683 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
684 [SessionCreate(0, 0);],
685 [ac_cv_use_security_session_api="yes"
686 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
687 [platform has the Security Authorization Session API])
688 LIBS="$LIBS -framework Security"
689 AC_MSG_RESULT([yes])],
690 [ac_cv_use_security_session_api="no"
691 AC_MSG_RESULT([no])])
692 AC_MSG_CHECKING([if we have an in-memory credentials cache])
693 AC_TRY_COMPILE(
694 [#include <Kerberos/Kerberos.h>],
695 [cc_context_t c;
696 (void) cc_initialize (&c, 0, NULL, NULL);],
697 [AC_DEFINE([USE_CCAPI], [1],
698 [platform uses an in-memory credentials cache])
699 LIBS="$LIBS -framework Security"
700 AC_MSG_RESULT([yes])
701 if test "x$ac_cv_use_security_session_api" = "xno"; then
702 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
703 fi],
704 [AC_MSG_RESULT([no])]
705 )
682 m4_pattern_allow([AU_IPv]) 706 m4_pattern_allow([AU_IPv])
683 AC_CHECK_DECL([AU_IPv4], [], 707 AC_CHECK_DECL([AU_IPv4], [],
684 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 708 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])