summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2004-04-04 14:59:15 +0000
committerColin Watson <cjwatson@debian.org>2004-04-04 14:59:15 +0000
commit66c48676d9e72463bdad1b1401bcac83848c282b (patch)
treec5816366fd752757569b0fd0957fb16de3c75dbe /debian/rules
parenta8edb34dd97fdb0bf0a56cf9d3a47ae33a53e29b (diff)
Some older kernels are missing setresuid() and setresgid(), so don't try to
use them. setreuid() and setregid() will do well enough for our purposes (closes: #239999).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c4c08eb0e..8cc9b5d9c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,6 +47,8 @@ build-deb-stamp:
47 dh_testdir 47 dh_testdir
48 mkdir -p build-deb 48 mkdir -p build-deb
49 cd build-deb && ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper 49 cd build-deb && ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper
50 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999).
51 perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h
50 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' 52 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign'
51 # Support building on Debian 3.0 (with GNOME 1.4) and later. 53 # Support building on Debian 3.0 (with GNOME 1.4) and later.
52 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ 54 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \