summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2006-03-31 08:19:19 +0000
committerColin Watson <cjwatson@debian.org>2006-03-31 08:19:19 +0000
commite4550711d01b9f23ec32c789ee747ebaa0b829df (patch)
tree808b3b043ad1e0606f851325aa2bd7ea78939c92 /debian
parent3f78d18ab53e1a3883c7042892ee52893ea7a82d (diff)
* Use udeb support introduced in debhelper 4.2.0 (available in sarge)
rather than constructing udebs by steam. * Require debhelper 5.0.22, which generates correct shared library dependencies for udebs. This build-dependency can be ignored if building on sarge.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules17
3 files changed, 20 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 43ec2115c..450a0a3ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
1openssh (1:4.2p1-8) UNRELEASED; urgency=low
2
3 [ Frans Pop ]
4 * Use udeb support introduced in debhelper 4.2.0 (available in sarge)
5 rather than constructing udebs by steam.
6 * Require debhelper 5.0.22, which generates correct shared library
7 dependencies for udebs. This build-dependency can be ignored if building
8 on sarge.
9
10 -- Colin Watson <cjwatson@debian.org> Fri, 31 Mar 2006 09:14:29 +0100
11
1openssh (1:4.2p1-7) unstable; urgency=low 12openssh (1:4.2p1-7) unstable; urgency=low
2 13
3 * I accidentally applied the default $PATH change in 1:4.2p1-6 to the udeb 14 * I accidentally applied the default $PATH change in 1:4.2p1-6 to the udeb
diff --git a/debian/control b/debian/control
index f0c53d040..73ef2afac 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: openssh
2Section: net 2Section: net
3Priority: standard 3Priority: standard
4Maintainer: Matthew Vernon <matthew@debian.org> 4Maintainer: Matthew Vernon <matthew@debian.org>
5Build-Depends: libwrap0-dev | libwrap-dev, zlib1g-dev | libz-dev, libssl-dev (>= 0.9.8-1), libpam0g-dev | libpam-dev, libgnomeui-dev (>= 2.0.0) | libgnome-dev, libedit-dev, groff, debhelper (>= 3), sharutils, libselinux1-dev [alpha amd64 arm armeb hppa i386 ia64 m68k mips mipsel powerpc ppc64 s390 sparc], libkrb5-dev 5Build-Depends: libwrap0-dev | libwrap-dev, zlib1g-dev | libz-dev, libssl-dev (>= 0.9.8-1), libpam0g-dev | libpam-dev, libgnomeui-dev (>= 2.0.0) | libgnome-dev, libedit-dev, groff, debhelper (>= 5.0.22), sharutils, libselinux1-dev [alpha amd64 arm armeb hppa i386 ia64 m68k mips mipsel powerpc ppc64 s390 sparc], libkrb5-dev
6Standards-Version: 3.6.2 6Standards-Version: 3.6.2
7Uploaders: Colin Watson <cjwatson@debian.org> 7Uploaders: Colin Watson <cjwatson@debian.org>
8 8
@@ -87,6 +87,7 @@ Description: under X, asks user for a passphrase for ssh-add
87 provided to add to your choice and/or confusion. 87 provided to add to your choice and/or confusion.
88 88
89Package: openssh-client-udeb 89Package: openssh-client-udeb
90XC-Package-Type: udeb
90Section: debian-installer 91Section: debian-installer
91Priority: optional 92Priority: optional
92Architecture: any 93Architecture: any
@@ -100,6 +101,7 @@ Description: Secure shell client for the Debian installer
100 This package provides the ssh client for use in debian-installer. 101 This package provides the ssh client for use in debian-installer.
101 102
102Package: openssh-server-udeb 103Package: openssh-server-udeb
104XC-Package-Type: udeb
103Section: debian-installer 105Section: debian-installer
104Priority: optional 106Priority: optional
105Architecture: any 107Architecture: any
diff --git a/debian/rules b/debian/rules
index 4707023bf..55de7927b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,8 +15,6 @@ else
15OPTFLAGS := -O0 15OPTFLAGS := -O0
16endif 16endif
17 17
18VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2 | sed 's/.*://')
19DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
20DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) 18DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null)
21 19
22# Take account of old dpkg-architecture output. 20# Take account of old dpkg-architecture output.
@@ -27,9 +25,6 @@ ifeq ($(DEB_HOST_ARCH_OS),)
27 endif 25 endif
28endif 26endif
29 27
30CLIENT_UDEB := openssh-client-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb
31SERVER_UDEB := openssh-server-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb
32
33ifeq (,$(wildcard /usr/bin/po2debconf)) 28ifeq (,$(wildcard /usr/bin/po2debconf))
34PO2DEBCONF := no 29PO2DEBCONF := no
35MINDEBCONFVER := 0.5 30MINDEBCONFVER := 0.5
@@ -278,9 +273,9 @@ binary-openssh-client-udeb: build install
278 dh_installdeb 273 dh_installdeb
279 install -p -o root -g root -m 755 debian/openssh-client-udeb.isinstallable debian/openssh-client-udeb/DEBIAN/isinstallable 274 install -p -o root -g root -m 755 debian/openssh-client-udeb.isinstallable debian/openssh-client-udeb/DEBIAN/isinstallable
280 dh_shlibdeps 275 dh_shlibdeps
281 dh_gencontrol -- -fdebian/files~ 276 dh_gencontrol
282 dpkg-distaddfile $(CLIENT_UDEB) debian-installer optional 277 dh_md5sums
283 dh_builddeb --filename=$(CLIENT_UDEB) 278 dh_builddeb
284 279
285binary-openssh-server-udeb: DH_OPTIONS=-popenssh-server-udeb 280binary-openssh-server-udeb: DH_OPTIONS=-popenssh-server-udeb
286binary-openssh-server-udeb: build install 281binary-openssh-server-udeb: build install
@@ -291,9 +286,9 @@ binary-openssh-server-udeb: build install
291 dh_fixperms 286 dh_fixperms
292 dh_installdeb 287 dh_installdeb
293 dh_shlibdeps 288 dh_shlibdeps
294 dh_gencontrol -- -fdebian/files~ 289 dh_gencontrol
295 dpkg-distaddfile $(SERVER_UDEB) debian-installer optional 290 dh_md5sums
296 dh_builddeb --filename=$(SERVER_UDEB) 291 dh_builddeb
297 292
298binary: binary-indep binary-arch 293binary: binary-indep binary-arch
299 294